napsgeareudomestic
finestgearsbannednutrition

Primo PIP and Inflammation

DL_00

Member
Hey guys... I've been running a cycle of Test P, Primo and Deca, all via Pharma Lady. Due to the overall volume required, I've simply been doing 1 shot per day, with no problems during the past 2 months. I just recently switched to some Primo from another one of the sponsors here (not sure if it'd be good etiquette to mention the name) and it's been rough. Extreme pain in the muscle injected for a good 3 to 4 days after the shot, as well as some inflammation. Made the mistake of doing a shot in the delt, and my whole lateral delt swole up to a deformed bulge (most capped delt I've ever had in my life though lol). Generally I rotate sites between outer quads and glutes. In these bigger muscles, I don't get as much swelling, but the pain almost makes me unable to function throughout my daily life. Hurts to sit down, walk around, etc. Is it a reason for concern my body is responding like this to this particular gear, or should I just suck it up and deal with the pain? I've never had this kind of PIP before with any of the other gear I've used. Thanks.
 

Iwannagofaster

VIP Member
I run primo every single cycle and the only time that primo didn't give me pip was the time that it was fake. That's just part of running real primo. It hurts but boy is it worth it. Nectar of the God's. Ibuprofen and Tylenol will take care of it. Be careful with the Tylenol though. It's liver toxic whereas Ibuprofen is not. Tylenol helps a lot but don't run too much while on anabolics. Your liver is already working overtime.

Sent from my Pixel 2 using Tapatalk
 

DylanGemelli

Founding Member
Super Moderator
its pretty normal to have PIP with primo man... ive had it less at times but its always there
 

Robfg71

Member
Member
I use Robos primo and it’s as smooth as butter. I don’t get any pip from it. But again before I inject anything I run it under super hot water and inject it slow and steady. I’ve shot as much as 4cc’s of it at once with no pip. Maybe try that or switch to Roboprimo. It’s g2g and come in 200mg per cc which helps for not having to inject as much or often when you do 600 to 800mg of it a week. Good luck bro.
 

DylanGemelli

Founding Member
Super Moderator
robos was the smoothest ive had but it did still have small amounts of pip but it was definitely one of the smoother
 

Robfg71

Member
Member
robos was the smoothest ive had but it did still have small amounts of pip but it was definitely one of the smoother

Yes the next day I’ll have a little pip just to know it’s real lol.....but nothing that causes any real discomfort. By the way love your videos and all your knowledge. This site has been a great resource. Keep up the great work and thanks for all you do.
 

DylanGemelli

Founding Member
Super Moderator
Yes the next day I’ll have a little pip just to know it’s real lol.....but nothing that causes any real discomfort. By the way love your videos and all your knowledge. This site has been a great resource. Keep up the great work and thanks for all you do.

Happy to help bro


Sent from my iPhone using Tapatalk Pro
 

DL_00

Member
I use Robos primo and it’s as smooth as butter. I don’t get any pip from it. But again before I inject anything I run it under super hot water and inject it slow and steady. I’ve shot as much as 4cc’s of it at once with no pip. Maybe try that or switch to Roboprimo. It’s g2g and come in 200mg per cc which helps for not having to inject as much or often when you do 600 to 800mg of it a week. Good luck bro.

Well since you mentioned it, it IS Robo's Primo I'm talking about. Was doing 1cc of Pharma Lady's Platinum Biotech every day with no issues. Switching to Robo, I've only been doing 1/2cc per shot (since it's 200 mg/ml) and it's killing me. The pain is so bad I can't even sleep at night. Can't lay on my back (glutes), can't lay on my stomach (quads). I could try the 'warming it up prior to injection' thing and inject extra slowly, but I cannot imagine that making much of a difference.
 

P0N

Community Leader
VIP Moderator
Warming before hand and injecting slowly definitely helps, and I always do it for every compound now. Follow it up with a hot shower or heating pad too, or even better work out the muscle group you just injected. None of this per se makes the compound have less PIP, but it gets it more spread out through the muscle group before the oil has dissipated. This means you that instead of a deposit in a small concentrated area causing intense pain, you get a much less intense (can be nearly none) ache over a larger part of the muscle.
 

Robfg71

Member
Member
Well since you mentioned it, it IS Robo's Primo I'm talking about. Was doing 1cc of Pharma Lady's Platinum Biotech every day with no issues. Switching to Robo, I've only been doing 1/2cc per shot (since it's 200 mg/ml) and it's killing me. The pain is so bad I can't even sleep at night. Can't lay on my back (glutes), can't lay on my stomach (quads). I could try the 'warming it up prior to injection' thing and inject extra slowly, but I cannot imagine that making much of a difference.

Hmm......that’s really weird I’ve shot about 5 bottles of his primo and have had only the normal little bit of pip the next day. No disrespect but you must be doing something wrong, maybe you hit a nerve or shooting it to fast or not going deep enough. Like I said when I shoot it I do 400mg at once. I use 25 gauge needle 1 1/2 inch long and it does help to have quality sharp needles. I don’t know I’m lost for words. I know his gear is g2g I don’t know him or get anything out of saying he’s good. Just my experience with his products. Your just having bad pip, rest assure though the gear is real and good. I had blood work done when I was running it with test before and my #’s were good. Then I just posted my blood work for running just his test cyp and those #’s are good. I can’t say the dose of primo is right or not but my #’s are always better then just the test cyp alone compares to the blood work when I run the test cyp with the primo. Peace out.✌🏻
 

Iwannagofaster

VIP Member
Some people react differently to different compounds. Most people get pip from primo. Some are lucky and don't. I pers2dint get much pip from test p but some do.

Sent from my Pixel 2 using Tapatalk
 

Buddhabuilder

Community Leader
VIP Moderator
I went straight to 2 cc’s of Robolics Primo twice a week and had zero pip...


Sent from my iPhone using Tapatalk
 

DylanGemelli

Founding Member
Super Moderator
all i know is that we have proper etiquette posted on how to handle ANY issue you have with any company, source etc. and that is to take it to them at all times and to NOT publicize things unless they are not working it out with you
 

DL_00

Member
Hmm......that’s really weird I’ve shot about 5 bottles of his primo and have had only the normal little bit of pip the next day. No disrespect but you must be doing something wrong, maybe you hit a nerve or shooting it to fast or not going deep enough.

Bro, no disrespect also, but I've ran numerous cycles of countless UGLs and different compounds, and never had a problem like this before. This current cycle, I pinned everyday for over 2 months without issue, but as soon as I switched my Primo, it's been hell. The first day, I thought yeah maybe it was just a bad injection because my whole delt swole up and was painful. But then I injected my glute the next day, then my other glute after that, and then my left quad, with the same results every day. It got to the point I couldn't take it anymore. My whole body was in so much pain I can't sit down, can barely shower or dress myself, can barely get any sleep, and I'm hobbling around at the with people wondering what is wrong with me. The only thing I can think is that for some reason, there is something about this specific gear my body is not reacting well to. I guess I can simply chalk it up to that.
 

DL_00

Member
all i know is that we have proper etiquette posted on how to handle ANY issue you have with any company, source etc. and that is to take it to them at all times and to NOT publicize things unless they are not working it out with you

Sorry Dylan, I'm not trying to criticize the source at all, as I know they're highly-regarded. I was just trying to figure out what was going on with me and if a reaction like this was normal.
 

DylanGemelli

Founding Member
Super Moderator
Sorry Dylan, I'm not trying to criticize the source at all, as I know they're highly-regarded. I was just trying to figure out what was going on with me and if a reaction like this was normal.

Its not uncommon to have pip with primo especially at a higher concentration


Sent from my iPhone using Tapatalk Pro
 

DL_00

Member
Some people react differently to different compounds. Most people get pip from primo. Some are lucky and don't. I pers2dint get much pip from test p but some do.

Sent from my Pixel 2 using Tapatalk

Yeah I've been running Test P with no prob. I know what normal PIP feels like, a little nuisance but nothing detrimental. But this here is on another level. I don't think it's the compound, because other Primo hasn't been an issue at all, but could it be an excipient or other ingredient in the specific gear??
 

Robfg71

Member
Member
Yeah I've been running Test P with no prob. I know what normal PIP feels like, a little nuisance but nothing detrimental. But this here is on another level. I don't think it's the compound, because other Primo hasn't been an issue at all, but could it be an excipient or other ingredient in the specific gear??

That could be the case. I know when I did DHB I had the exact pip you are talking about it was killing me. So I understand the wondering about it. But what was weird is sometimes I would pin it and the pip was just normal pip pain the next day. Then other times I would pip it from the very same bottle and it would kill me. So what I did was mix the DHB with test and tren all in the same syringe 1cc of the DHB then the tren then the test. So when I pinned it the test was going in first then the tren then last the DHB after that there was no more crazy pip. So try mixing it with your test cyp and run it under super hot water and inject it slow and steady. Then let us know if that helped. Cheers
 
Top